const regex = /(?<=\w{4})\h+(?=\w{4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\w{4})\\h+(?=\\w{4})', 'gm')
const str = `check24 smavey dr klein
smava
check24, interhyp
verivox check24 dr. klein
dr. klein
NA
dr. weber
dr. klein,
NA
check24
check24 verivox
Name1, Name2 Name3
Dr. Name1 Name2 Name3
AAA AAAA AAAA AAAA`;
const subst = `_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);