import Foundation
let pattern = #"(?<=\w{4})\h+(?=\w{4})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
check24 smavey dr klein
smava
check24, interhyp
verivox check24 dr. klein
dr. klein
NA
dr. weber
dr. klein,
NA
check24
check24 verivox
Name1, Name2 Name3
Dr. Name1 Name2 Name3
AAA AAAA AAAA AAAA
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)