using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\w{4})\h+(?=\w{4})";
string substitution = @"_";
string input = @"check24 smavey dr klein
smava
check24, interhyp
verivox check24 dr. klein
dr. klein
NA
dr. weber
dr. klein,
NA
check24
check24 verivox
Name1, Name2 Name3
Dr. Name1 Name2 Name3
AAA AAAA AAAA AAAA";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}