using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\${[^{}]*\${([^{}]*)}[^{}]*}";
string input = @"text1${text2${text3}text4}text5
- match ""text3""
text1text2${text3}text4text5
- should not match anything
text1${text2${text3}text4text5
- should not match anything";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}