import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$\\{[^\\{\\}]*\\$\\{([^\\{\\}]*)\\}[^\\{\\}]*\\}";
final String string = "text1${text2${text3}text4}text5\n"
+ " - match \"text3\"\n"
+ "text1text2${text3}text4text5\n"
+ " - should not match anything\n"
+ "text1${text2${text3}text4text5\n"
+ " - should not match anything";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}