import re
regex = re.compile(r"\${[^{}]*\${([^{}]*)}[^{}]*}")
test_str = ("text1${text2${text3}text4}text5\n"
" - match \"text3\"\n"
"text1text2${text3}text4text5\n"
" - should not match anything\n"
"text1${text2${text3}text4text5\n"
" - should not match anything")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")