$re = '/\${[^{}]*\${([^{}]*)}[^{}]*}/';
$str = 'text1${text2${text3}text4}text5
- match "text3"
text1text2${text3}text4text5
- should not match anything
text1${text2${text3}text4text5
- should not match anything';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);