re = /\${[^{}]*\${([^{}]*)}[^{}]*}/
str = 'text1${text2${text3}text4}text5
- match "text3"
text1text2${text3}text4text5
- should not match anything
text1${text2${text3}text4text5
- should not match anything'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end