#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bvari?((?<=i)a)?((?<=a)b)?((?<=b)l)?((?<=l)e)?\b"
Local $sString = "var name" & @CRLF & _
"vari name" & @CRLF & _
"varia name" & @CRLF & _
"variab name" & @CRLF & _
"variabl name" & @CRLF & _
"variable name" & @CRLF & _
"vard name" & @CRLF & _
"va name"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")