const regex = /\bvari?((?<=i)a)?((?<=a)b)?((?<=b)l)?((?<=l)e)?\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bvari?((?<=i)a)?((?<=a)b)?((?<=b)l)?((?<=l)e)?\\b', 'g')
const str = `var name
vari name
varia name
variab name
variabl name
variable name
vard name
va name`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}