import re
regex = re.compile(r"\bvari?((?<=i)a)?((?<=a)b)?((?<=b)l)?((?<=l)e)?\b")
test_str = ("var name\n"
"vari name\n"
"varia name\n"
"variab name\n"
"variabl name\n"
"variable name\n"
"vard name\n"
"va name")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")