$re = '/\bvari?((?<=i)a)?((?<=a)b)?((?<=b)l)?((?<=l)e)?\b/';
$str = 'var name
vari name
varia name
variab name
variabl name
variable name
vard name
va name';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);