using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"s\((?<!\-)(\d+)(.+\n)(?:((?:s\((?=\-).+\d+\n)+)|(s\((?=\-).+))+";
string substitution = @"s($1$2$3$4 --$1";
string input = @"s(1059,""Amani Mail"",{69603,69640,69580,69616,69561,69590,94216},nil)
s(-1060,""Amani Mail (Recolor)"",{33464,33286,33533,33469,33535,94079,94083,94078},nil)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}