import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "s\\((?<!\\-)(\\d+)(.+\\n)(?:((?:s\\((?=\\-).+\\d+\\n)+)|(s\\((?=\\-).+))+";
final String string = "s(1059,\"Amani Mail\",{69603,69640,69580,69616,69561,69590,94216},nil) \n"
+ "s(-1060,\"Amani Mail (Recolor)\",{33464,33286,33533,33469,33535,94079,94083,94078},nil)";
final String subst = "s($1$2$3$4 --$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}