import re
regex = re.compile(r"s\((?<!\-)(\d+)(.+\n)(?:((?:s\((?=\-).+\d+\n)+)|(s\((?=\-).+))+")
test_str = ("s(1059,\"Amani Mail\",{69603,69640,69580,69616,69561,69590,94216},nil) \n"
"s(-1060,\"Amani Mail (Recolor)\",{33464,33286,33533,33469,33535,94079,94083,94078},nil)")
subst = "s($1$2$3$4 --$1"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)