const regex = /s\((?<!\-)(\d+)(.+\n)(?:((?:s\((?=\-).+\d+\n)+)|(s\((?=\-).+))+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('s\\((?<!\\-)(\\d+)(.+\\n)(?:((?:s\\((?=\\-).+\\d+\\n)+)|(s\\((?=\\-).+))+', '')
const str = `s(1059,"Amani Mail",{69603,69640,69580,69616,69561,69590,94216},nil)
s(-1060,"Amani Mail (Recolor)",{33464,33286,33533,33469,33535,94079,94083,94078},nil)`;
const subst = `s($1$2$3$4 --$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);