use strict;
my $str = 's(1059,"Amani Mail",{69603,69640,69580,69616,69561,69590,94216},nil)
s(-1060,"Amani Mail (Recolor)",{33464,33286,33533,33469,33535,94079,94083,94078},nil)';
my $regex = qr/s\((?<!\-)(\d+)(.+\n)(?:((?:s\((?=\-).+\d+\n)+)|(s\((?=\-).+))+/p;
my $subst = 's($1$2$3$4 --$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";