#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*zz\s*:\s*(.*)[\n\r]"
Local $sString = "{" & @CRLF & _
" xx : " & @CRLF & _
" yy :" & @CRLF & _
" zz : sample 123123" & @CRLF & _
"}" & @CRLF & _
"HTTP/1.1 202... blah blah blah" & @CRLF & _
"Content-Length: 35" & @CRLF & _
"X-Frame-Options: deny" & @CRLF & _
"X-XSS-Protection: 1; mode=block" & @CRLF & _
"X-Content-Type-Options: nosniff" & @CRLF & _
"Connection: close"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")