re = /.*zz\s*:\s*(.*)[\n\r]/
str = '{
xx :
yy :
zz : sample 123123
}
HTTP/1.1 202... blah blah blah
Content-Length: 35
X-Frame-Options: deny
X-XSS-Protection: 1; mode=block
X-Content-Type-Options: nosniff
Connection: close'
# Print the match result
str.match(re) do |match|
puts match.to_s
end