import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*zz\\s*:\\s*(.*)[\\n\\r]";
final String string = "{\n"
+ " xx : \n"
+ " yy :\n"
+ " zz : sample 123123\n"
+ "}\n"
+ "HTTP/1.1 202... blah blah blah\n"
+ "Content-Length: 35\n"
+ "X-Frame-Options: deny\n"
+ "X-XSS-Protection: 1; mode=block\n"
+ "X-Content-Type-Options: nosniff\n"
+ "Connection: close";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}