using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*zz\s*:\s*(.*)[\n\r]";
string input = @"{
xx :
yy :
zz : sample 123123
}
HTTP/1.1 202... blah blah blah
Content-Length: 35
X-Frame-Options: deny
X-XSS-Protection: 1; mode=block
X-Content-Type-Options: nosniff
Connection: close";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}