package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*zz\s*:\s*(.*)[\n\r]`)
var str = `{
xx :
yy :
zz : sample 123123
}
HTTP/1.1 202... blah blah blah
Content-Length: 35
X-Frame-Options: deny
X-XSS-Protection: 1; mode=block
X-Content-Type-Options: nosniff
Connection: close`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}