#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=\s)(?!\S*level[0-9])[^\s#*]+(?=\s)"
Local $sString = "How to write regex which find word (without whitespace) that doesn't contain some chars (like * or #) and sentence also (like level10 or level2 - it should be also regex - level[0-9]+). It will be simple for chars excluded ([^\\s^#^*]+) but how to exclude this 'level' example too ?" & @CRLF & _
"" & @CRLF & _
"I want to exclude chars AND level with number." & @CRLF & _
"" & @CRLF & _
"Examples:" & @CRLF & _
"weesdlevel3fv - shouldn't match because of 'level3'" & @CRLF & _
"we3rlevelw4erw - should match - there is level without number" & @CRLF & _
"dfs3leveldfvws#3vd - shouldn't match - level is good, but '#' char appeared" & @CRLF & _
"level4#level levelw4_level - threat as two words because of whitespaces - only second one should match - no levels with number and no restricted chars like '#' or '*'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")