import Foundation
let pattern = ##"(?<=\s)(?!\S*level[0-9])[^\s#*]+(?=\s)"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
How to write regex which find word (without whitespace) that doesn't contain some chars (like * or #) and sentence also (like level10 or level2 - it should be also regex - level[0-9]+). It will be simple for chars excluded ([^\\s^#^*]+) but how to exclude this 'level' example too ?
I want to exclude chars AND level with number.
Examples:
weesdlevel3fv - shouldn't match because of 'level3'
we3rlevelw4erw - should match - there is level without number
dfs3leveldfvws#3vd - shouldn't match - level is good, but '#' char appeared
level4#level levelw4_level - threat as two words because of whitespaces - only second one should match - no levels with number and no restricted chars like '#' or '*'
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)