const regex = /(?<=\s)(?!\S*level[0-9])[^\s#*]+(?=\s)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\s)(?!\\S*level[0-9])[^\\s#*]+(?=\\s)', 'g')
const str = `How to write regex which find word (without whitespace) that doesn't contain some chars (like * or #) and sentence also (like level10 or level2 - it should be also regex - level[0-9]+). It will be simple for chars excluded ([^\\\\s^#^*]+) but how to exclude this 'level' example too ?
I want to exclude chars AND level with number.
Examples:
weesdlevel3fv - shouldn't match because of 'level3'
we3rlevelw4erw - should match - there is level without number
dfs3leveldfvws#3vd - shouldn't match - level is good, but '#' char appeared
level4#level levelw4_level - threat as two words because of whitespaces - only second one should match - no levels with number and no restricted chars like '#' or '*'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}