# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\s)(?!\S*level[0-9])[^\s#*]+(?=\s)"
test_str = ("How to write regex which find word (without whitespace) that doesn't contain some chars (like * or #) and sentence also (like level10 or level2 - it should be also regex - level[0-9]+). It will be simple for chars excluded ([^\\\\s^#^*]+) but how to exclude this 'level' example too ?\n\n"
"I want to exclude chars AND level with number.\n\n"
"Examples:\n"
"weesdlevel3fv - shouldn't match because of 'level3'\n"
"we3rlevelw4erw - should match - there is level without number\n"
"dfs3leveldfvws#3vd - shouldn't match - level is good, but '#' char appeared\n"
"level4#level levelw4_level - threat as two words because of whitespaces - only second one should match - no levels with number and no restricted chars like '#' or '*'")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.