package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a .*? style="text-decoration:none;color:#676c6c".*?>.*?<\/a>`)
var str = `<a href="http://SOME-RANDOM-LINK-HERE.com/" style="text-decoration:none;color:#676c6c">SOME RANDOM TEXT HERE</a>
<div id="something">
This is something which wont be deleted.
</div>
<a href="something" style="something"> This should not be deleted </a>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}