re = /<a .*? style="text-decoration:none;color:#676c6c".*?>.*?<\/a>/
str = '<a href="http://SOME-RANDOM-LINK-HERE.com/" style="text-decoration:none;color:#676c6c">SOME RANDOM TEXT HERE</a>
<div id="something">
This is something which wont be deleted.
</div>
<a href="something" style="something"> This should not be deleted </a>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end