import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a .*? style=\"text-decoration:none;color:#676c6c\".*?>.*?<\\/a>";
final String string = "<a href=\"http://SOME-RANDOM-LINK-HERE.com/\" style=\"text-decoration:none;color:#676c6c\">SOME RANDOM TEXT HERE</a>\n"
+ "<div id=\"something\">\n"
+ "This is something which wont be deleted.\n"
+ "</div>\n"
+ "<a href=\"something\" style=\"something\"> This should not be deleted </a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}