import Foundation
let pattern = ##"<a .*? style="text-decoration:none;color:#676c6c".*?>.*?<\/a>"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<a href="http://SOME-RANDOM-LINK-HERE.com/" style="text-decoration:none;color:#676c6c">SOME RANDOM TEXT HERE</a>
<div id="something">
This is something which wont be deleted.
</div>
<a href="something" style="something"> This should not be deleted </a>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}