#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.)[+#*]?\d*?(?:X+|\*)?$"
Local $sString = "12345X" & @CRLF & _
"12345XX" & @CRLF & _
"1234XXXXXX" & @CRLF & _
"1234XXXXXX*" & @CRLF & _
"XXXXXX" & @CRLF & _
"1234*" & @CRLF & _
"1234556*" & @CRLF & _
"1234556**" & @CRLF & _
"1*" & @CRLF & _
"*" & @CRLF & _
"" & @CRLF & _
"012345" & @CRLF & _
"+12345" & @CRLF & _
"#1234525"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")