$re = '/^(?=.)[+#*]?\d*?(?:X+|\*)?$/m';
$str = '12345X
12345XX
1234XXXXXX
1234XXXXXX*
XXXXXX
1234*
1234556*
1234556**
1*
*
012345
+12345
#1234525';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);