import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.)[+#*]?\\d*?(?:X+|\\*)?$";
final String string = "12345X\n"
+ "12345XX\n"
+ "1234XXXXXX\n"
+ "1234XXXXXX*\n"
+ "XXXXXX\n"
+ "1234*\n"
+ "1234556*\n"
+ "1234556**\n"
+ "1*\n"
+ "*\n\n"
+ "012345\n"
+ "+12345\n"
+ "#1234525";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}