re = /^(?=.)[+#*]?\d*?(?:X+|\*)?$/m
str = '12345X
12345XX
1234XXXXXX
1234XXXXXX*
XXXXXX
1234*
1234556*
1234556**
1*
*
012345
+12345
#1234525'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end