using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.)[+#*]?\d*?(?:X+|\*)?$";
string input = @"12345X
12345XX
1234XXXXXX
1234XXXXXX*
XXXXXX
1234*
1234556*
1234556**
1*
*
012345
+12345
#1234525";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}