#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^" & @CRLF & _
" (\d|[1-9]\d|1\d\d|2" & @CRLF & _
" ([0-4]\d|5[0-5])" & @CRLF & _
" )" & @CRLF & _
" \." & @CRLF & _
" (\d|[1-9]\d|1\d\d|2" & @CRLF & _
" ([0-4]\d|5[0-5])" & @CRLF & _
" )" & @CRLF & _
" \." & @CRLF & _
" (\d|[1-9]\d|1\d\d|2" & @CRLF & _
" ([0-4]\d|5[0-5])" & @CRLF & _
" )" & @CRLF & _
" \." & @CRLF & _
" (0|64|128|192)" & @CRLF & _
"$"
Local $sString = "172.17.251.64" & @CRLF & _
"172.17.251.200"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")