import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ " (\\d|[1-9]\\d|1\\d\\d|2\n"
+ " ([0-4]\\d|5[0-5])\n"
+ " )\n"
+ " \\.\n"
+ " (\\d|[1-9]\\d|1\\d\\d|2\n"
+ " ([0-4]\\d|5[0-5])\n"
+ " )\n"
+ " \\.\n"
+ " (\\d|[1-9]\\d|1\\d\\d|2\n"
+ " ([0-4]\\d|5[0-5])\n"
+ " )\n"
+ " \\.\n"
+ " (0|64|128|192)\n"
+ "$";
final String string = "172.17.251.64\n"
+ "172.17.251.200";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}