const regex = /^
(\d|[1-9]\d|1\d\d|2
([0-4]\d|5[0-5])
)
\.
(\d|[1-9]\d|1\d\d|2
([0-4]\d|5[0-5])
)
\.
(\d|[1-9]\d|1\d\d|2
([0-4]\d|5[0-5])
)
\.
(0|64|128|192)
$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^
(\\d|[1-9]\\d|1\\d\\d|2
([0-4]\\d|5[0-5])
)
\\.
(\\d|[1-9]\\d|1\\d\\d|2
([0-4]\\d|5[0-5])
)
\\.
(\\d|[1-9]\\d|1\\d\\d|2
([0-4]\\d|5[0-5])
)
\\.
(0|64|128|192)
$', 'gm')
const str = `172.17.251.64
172.17.251.200`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}