package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^
(\d|[1-9]\d|1\d\d|2
([0-4]\d|5[0-5])
)
\.
(\d|[1-9]\d|1\d\d|2
([0-4]\d|5[0-5])
)
\.
(\d|[1-9]\d|1\d\d|2
([0-4]\d|5[0-5])
)
\.
(0|64|128|192)
$`)
var str = `172.17.251.64
172.17.251.200`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}