package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b(?:\w+\W+){0,20}(?:BADWORD1|BAD2)\b(?:\W+\w+){0,20}|\b(PRIMARY1|P2|P3)\b|\b(SECONDARY1|S2|S3)\W+(?:\w+\W+){0,20}(TERTIARY1|T2|T3)\b|\b(TERTIARY1|T2|T3)\W+(?:\w+\W+){0,20}(SECONDARY1|S2|S3)\b`)
var str = `word word word word word word word word word word word word word word word PRIMARY1 . . . . . . . . . . . . . . . .
word word word word word word word word word word word word word word word word word word word word word BADWORD1 word word word word word word word word word word PRIMARY1 . . . . . . . . . . . . . . . .
word word word word word word word word word word word word word word word word word word word word word BADWORD1 word word word word word word word word word word SECONDARY1 word word word word word word word word TERTIARY1. . . . . . . . . . . . . . . . . . . . . . . . . . . .
word word word word word word word word word word word word word word word word word word word word word word word word word word word word word word SECONDARY1 word word word word word word word word TERTIARY1. . . . . . . . . . . . . . . . . . . . . . . . . . . .
word word word word word word word word word word word word word word word word word word word word word BADWORD1 word word word word word word word word word word word <MORE THAN 20 WORDS AWAY FROM BAD> word word word TERTIARY1 word word word word word word word word SECONDARY1. . . . . . . . . . . . . . . . . . . . . . . . . . . .`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}