#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\s)#\w{1,5}\b"
Local $sString = "'Rock#car2' should pass" & @CRLF & _
"" & @CRLF & _
"'R o ck#car2' should pass" & @CRLF & _
"" & @CRLF & _
"'Rock #car2' should fail" & @CRLF & _
"" & @CRLF & _
"'Rock#car12345' should fail" & @CRLF & _
"" & @CRLF & _
"'Rock#' should fail"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")