const regex = /(?<!\s)#\w{1,5}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\s)#\\w{1,5}\\b', 'gm')
const str = `'Rock#car2' should pass
'R o ck#car2' should pass
'Rock #car2' should fail
'Rock#car12345' should fail
'Rock#' should fail`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}