re = /(?<!\s)#\w{1,5}\b/m
str = '\'Rock#car2\' should pass
\'R o ck#car2\' should pass
\'Rock #car2\' should fail
\'Rock#car12345\' should fail
\'Rock#\' should fail'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end