import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\s)#\\w{1,5}\\b";
final String string = "'Rock#car2' should pass\n\n"
+ "'R o ck#car2' should pass\n\n"
+ "'Rock #car2' should fail\n\n"
+ "'Rock#car12345' should fail\n\n"
+ "'Rock#' should fail";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}