using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\s)#\w{1,5}\b";
string input = @"'Rock#car2' should pass
'R o ck#car2' should pass
'Rock #car2' should fail
'Rock#car12345' should fail
'Rock#' should fail";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}