#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\{word\}(*SKIP)(*F)|word"
Local $sString = "before a comma word," & @CRLF & _
"end of sentence word." & @CRLF & _
"end of line word" & @CRLF & _
"word at line start" & @CRLF & _
"prefix-word pattern" & @CRLF & _
"and word-postfix pattern" & @CRLF & _
"but not {word} as a tag" & @CRLF & _
"neither {word} nor" & @CRLF & _
"{word} here" & @CRLF & _
"word" & @CRLF & _
"{word}" & @CRLF & _
"{word should match " & @CRLF & _
"this should match too word}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")