const regex = /\{word\}(*SKIP)(*F)|word/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{word\\}(*SKIP)(*F)|word', 'gm')
const str = `before a comma word,
end of sentence word.
end of line word
word at line start
prefix-word pattern
and word-postfix pattern
but not {word} as a tag
neither {word} nor
{word} here
word
{word}
{word should match
this should match too word}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}