# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\{word\}(*SKIP)(*F)|word"
test_str = ("before a comma word,\n"
"end of sentence word.\n"
"end of line word\n"
"word at line start\n"
"prefix-word pattern\n"
"and word-postfix pattern\n"
"but not {word} as a tag\n"
"neither {word} nor\n"
"{word} here\n"
"word\n"
"{word}\n"
"{word should match \n"
"this should match too word}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.