import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{word\\}(*SKIP)(*F)|word";
final String string = "before a comma word,\n"
+ "end of sentence word.\n"
+ "end of line word\n"
+ "word at line start\n"
+ "prefix-word pattern\n"
+ "and word-postfix pattern\n"
+ "but not {word} as a tag\n"
+ "neither {word} nor\n"
+ "{word} here\n"
+ "word\n"
+ "{word}\n"
+ "{word should match \n"
+ "this should match too word}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}