package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{word\}(*SKIP)(*F)|word`)
var str = `before a comma word,
end of sentence word.
end of line word
word at line start
prefix-word pattern
and word-postfix pattern
but not {word} as a tag
neither {word} nor
{word} here
word
{word}
{word should match
this should match too word}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}